Atmega8 i najnowsze Arduino IDE (1.6.6)

Kiedy zachciałem wgrywać programy z Arduino IDE na Atmegę8 pojawił się problem – większość opisów jak dodać obsługę tego AVRa dotyczyła starego IDE albo i tak nie działało z najświeższymi wersjami. Najpierw sam coś posklejałem, później znalazłem na githubie optiboot, niestety z Atmega8 nie działał „out-of-box” ponieważ ArduinoIDE chciało korzystać z extended_fuses, a i sam bootloader w wersji skompilowanej nie był w paczce. Z tym też sobie poradziłem, wynik jest do pobrania jako załącznik do poprzedniego postu po angielsku. W końcu jednak trafiłem na fajne repozytorium, które daje bardzo dobre wsparcie dla mniej popularnych Atmeg i dodatkowo wystarczy tylko w Preferencjach IDE podać lokalizację pliku json. Wszystko tutaj: https://github.com/sleemanj/optiboot

Ten wpis został opublikowany w kategorii Arduino, Atmega, embedded. Dodaj zakładkę do bezpośredniego odnośnika.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *